Provider for Google Calendar cronologia delle versioni

45 versioni

Fai attenzione alle vecchie versioni!

Queste versioni sono visualizzate solo per scopo di test e archivio. Dovresti sempre utilizzare l’ultima versione di un componente aggiuntivo.

Versione 102.0.0 171.3 KiB Compatibile con Thunderbird 91.0 - 103.0

Bug Fixes

Correctly do partial task sync (cb8dc66)
Correctly set document title for migration dialog (d9dec28), closes #398
Persist forcing plain text (98a90ee), closes #412
Remove unnecessary URL import (581effb)
Update for bug 1690390 - Parameters of NotificationBox appendNotification changed (4e89b40)
Update for bug 1693873 - Use async calendar operations (92bc1d8)
Update for bug 1759768 - Changed calendar service getters (e6c674c)

Features

Mitigate rate limit exceeded errors by disabling calendars (b0942c0)
Show error message in new calendar wizard (34347a6)

Versione 91.0.4 170.2 KiB Compatibile con Thunderbird 91.0 - 102.0

Re-use same key as 91.0.2 to avoid rate limit exceeded errors

Versione 91.0.3 170.2 KiB Compatibile con Thunderbird 91.0 - 102.0

Bug Fixes

Correctly display activity manager stats (5b73f70)
Save settings under the correct key (6f01889), closes #312

Features

Add an option to force use of plain text for descriptions (08b4c4c), closes #316

Versione 91.0.2 170.2 KiB Compatibile con Thunderbird 91.0 - 102.0

Bug Fixes

Accept if Calendars or Tasks are disabled in G Suite (a2bfe48), closes #65
Avoid asking for changes when none have been made (8226cd7), closes #11
Correctly include organizer as attendee (f05f6c9), closes #62
Correctly set cookie exceptions to make logins work (ecc6781), closes #43
Don't show the migration dialog again when cancelled (faf2124)
Make sure sync prefs are available at startup (18acb63)
Port bug 1687612 - Fix new account OAuth window to be E10s capable. (44a563a)
Properly display HTML from description (6625aba)
Refresh completed/hidden tasks as well (3a0cf1a), closes #72
Remove error about aRequest.name not being implemented (3e0162e)
Resolve cyclic dependency and incorrect parameters in freebusy service calls (d5c72bb), closes #147
Still detect code if redirect is redirected to https (c5e1090), closes #227
Trailing slash on completion URI (dad61c9)
Use a different port number to avoid collisions (5a57421), closes #240
Use migrated preferences instead of purged legacy prefs (8a86dd5), closes #191
Use oob mechanism for OAuth instead (6b243be), closes #240

Features

Go back to the session page if auth dialog is canceled (4969f6f)
Invalidate session when password is removed (abd16b1)
Options UI for invitations options (abc3a41)
Roundtrip color id so it is not removed (90121ab), closes #236

Versione 91.0.1 167.7 KiB Compatibile con Thunderbird 91.0 - 102.0

Versione 78.0.2 167.8 KiB Compatibile con Thunderbird 78.2.0 - 78.*

## [78.0.2](https://github.com/kewisch/gdata-provider/compare/v78.0.1...v78.0.2) (2021-08-29)


### Bug Fixes

* Limit compatibility to 78 to work around ATN bug ([602fe6d](https://github.com/kewisch/gdata-provider/commit/602fe6d08b16b481dbfd4efd3f34ebf24f4f4368))
* Avoid failure in saveReminder if defaultReminders is undefined ([f6e3bab](https://github.com/kewisch/gdata-provider/commit/f6e3babf9de0911a9b7aa3a58f3493cc79694c60))

Versione 78.0.1 176.8 KiB Compatibile con Thunderbird 78.2.0 - 78.*

Versione 68.2.1 237.8 KiB Compatibile con Thunderbird 68.0 - 73.0

* Fixed "Malformed auth code" error (#23)

Versione 68.0 228.4 KiB Compatibile con Thunderbird 68.0 - 73.0

Versione 68.0b6 289.7 KiB Compatibile con Thunderbird 68.0 - 73.0

Versione 4.4.2 245.8 KiB Compatibile con SeaMonkey 2.49 - 2.60a1, Thunderbird 52.0 - 63.0a1

Versione 4.4.1 245.8 KiB Compatibile con SeaMonkey 2.49 - 2.60a1, Thunderbird 52.0 - 63.0a1

Versione 4.4 245.8 KiB Compatibile con SeaMonkey 2.49 - 2.60a1, Thunderbird 52.0 - 63.0a1

Versione 3.3 221.0 KiB Compatibile con SeaMonkey 2.21 - 2.49.*, Thunderbird 24.0 - 52.*

Versione 3.1 213.2 KiB Compatibile con SeaMonkey 2.21 - 2.47.*, Thunderbird 24.0 - 50.*

Versione 2.7 210.9 KiB Compatibile con SeaMonkey 2.21 - 2.41a1, Thunderbird 24.0 - 50.0a1

Versione 1.0.4 89.3 KiB Compatibile con SeaMonkey 2.21 - 2.35a1, Thunderbird 24.0 - 38.*

  • Bug 1130902 - Notifications are now correctly sent when modifying events
  • Bug 1126338 - Fixed creating events without an organizer but with attendees
  • Bug 1128258 - Fixed an error in the attendees dialog with "entry.interval is undefined"
  • Bug 1127247 - Correctly create events in UTC timezone
  • Bug 1124154 - Wait for parsing to complete before completing synchronization
  • Bug 1116227 - Fix incorrectly defined string shims
  • Bug 1101175 - Improve invitations handling
  • Bug 1117339 - Thunderbird 24 doesn't support using Promise as a constructor
  • Bug 1110881 - Google login popup gives no context
  • Bug 1117540 - Fixed setting default alarm props on calendars without default alarm
  • Bug 1117340 - Task lists now work for calendar entries without a calendar (regression)
  • Bug 1117341 - Outdated client message shown when using obsolete token

Versione 1.0.3 86.7 KiB Compatibile con SeaMonkey 2.21 - 2.33a1, Thunderbird 24.0 - 36.0a1

  • Compatibility for Postbox 3
  • Recurring events no longer disappear when modified
  • Recurring alarms are correctly snoozed.
  • Fixed error "this.mDeferred is null" when login fails
  • Removed lots of debugging messages
  • Improved module filesystem layout
  • Back Button in new calendar wizard no longer causes double-subscriptions
  • Fix bug 1061363 - Syncing Lightning w/GDATA Provider blocks UI thread.
  • Fix bug 1103637 - Calendars get disabled when in offline mode
  • Fix bug 1082478 - Use application locale when showing OAuth window.
  • Fix bug 1085287 - Invalid time zone definition for start time.
  • Fix bug 1083934 - Google calendar provider ignores default new event/task reminder setting.

If you continue to experience issues with events no longer showing, please file a bug or visit the support forum.

Versione 1.0.2 68.5 KiB Compatibile con SeaMonkey 2.21 - 2.31a1, Thunderbird 24.0 - 34.0a1

  • Users were confused because the new calendar wizard changed, added descriptive text.
  • Refresh intervals smaller than 30 minutes are prohibited due to quota issues
  • Calendar is no longer refreshed when user is idle
  • Bumped number of results per request from 50 to 1000
  • Various issues w.r.t. showing correct messages on quota or login errors

Versione 1.0.1 67.1 KiB Compatibile con SeaMonkey 2.21 - 2.31a1, Thunderbird 24.0 - 34.0a1

The Provider for Google Calendar 1.0 is a complete rewrite of the previous version and now uses v3 of the Google Calendar API.

The main new feature is tasks support. If you have previously been using the Provider for Google Calendar, the main calendar per account will automatically use the default tasks list. If you are missing a calendar or tasks list, you can use the new calendar selection dialog to add it to your calendars list.

Unfortunately this version is English only. More locales will be added as soon as the code has been pushed to the Mozilla repositories and the localizers catch up.

Version 1.0.1 fixes a few issues that users have had from the now removed version 1.0. If you experience any issues with this release, please feel free to visit the support site.

Versione 0.32 111.6 KiB Compatibile con SeaMonkey 2.22 - 2.28.*, Thunderbird 25.0 - 31.*

Versione 0.25 112.3 KiB Compatibile con SeaMonkey 2.14 - 2.22.*, Thunderbird 17.0 - 25.*

Versione 0.18 126.0 KiB Compatibile con SeaMonkey 2.14 - 2.14.*, Thunderbird 17.0 - 24.*

Versione 0.17 138.0 KiB Compatibile con SeaMonkey 2.12 - 2.13.*, Thunderbird 15.0 - 16.*

Versione 0.16 154.0 KiB Compatibile con SeaMonkey 2.12 - 2.12.*, Thunderbird 15.0 - 15.*

Versione 0.13 59.0 KiB Compatibile con SeaMonkey 2.5a1 - 2.11.*, Thunderbird 8.0a1 - 14.*

Versione 0.9 182.0 KiB Compatibile con SeaMonkey 2.5a1 - 2.10.*, Thunderbird 8.0a1 - 14.*

This version fixes the following bug:

bug 735619 - Event is moved from original calendar to primary Google calendar upon editing (regression)."

Versione 0.8 166.0 KiB Compatibile con SeaMonkey 2.1 - 2.4.*, Thunderbird 5.0b1 - 7.*

This version of the Provider for Google Calendar REQUIRES a Lightning version between 1.0b4 and 1.0b7. Lightning 1.0b7 REQUIRES Thunderbird 7 or Seamonkey 2.4.

Sunbird 1.0b1 users, please click on "View All Versions" and and make use of the Provider for Google Calendar 0.6b1.

This version is translated into the same locales that are shipped with Lightning 1.0b7. If you would like to use the Provider with a later version of Lightning, you need to use a Provider nightly from the Mozilla FTP Servers.
For compatibility between Lightning and Thunderbird, please see the Calendar Versions page

Note that it is not possible to accept an invitation received via email onto your Google Calendar. To correctly use invitations, please be sure to enable the "Automatically add invitations to my calendar" option, invitations will then automatically be shown in the application's invitation manager or in the calendar views.

Versione 0.7.1 111.0 KiB Compatibile con Thunderbird 3.1 - 3.1.*

This version of the Provider for Google Calendar REQUIRES Lightning 1.0b2. Lightning 1.0b2 REQUIRES Thunderbird 3.1 or later.
Sunbird 1.0b1 users, please visit the "previous versions" section and make use of the Provider for Google Calendar 0.6b1.
This version is translated into the same locales that are shipped with Lightning 1.0b2. If you would like to use the Provider with a 1.0b3pre version, you need to use a Provider nightly from :
ftp://ftp.mozilla.org/pub/calendar/lightning/nightly/latest-comm-1.9.2/
The same goes for 1.1a1pre, you'll need the Provider nightly from:
ftp://ftp.mozilla.org/pub/calendar/lightning/nightly/latest-comm-central/

Note that it is not possible to accept an invitation received via email onto your Google Calendar. To correctly use invitations, please be sure to enable the "Automatically add invitations to my calendar" option, invitations will then automatically be shown in the application's invitation manager or in the calendar views.

Version 0.7.1 is identical to 0.7 but adds support for Postbox and Lightning Inverse Edition.

Versione 0.7 111.0 KiB Compatibile con Thunderbird 3.1 - 3.1.*