Noté 4 sur 5 étoiles

Da die Webseite des Authors nicht mehr existiert, schreibe ich hier mal hin, was notwendig ist, um es kompatibel mit Thunderbird 57 und höher zu machen.

Datei chrome/content/clamdrib.js

- Zeile 136
-- alt: pump.init(msgInStream, -1, -1, 0, 0, false);
-- neu: pump.init(msgInStream, 0, 0, false);

- Zeile 267:
-- alt: pump.init(clamdInStream, -1, -1, 0, 0, false);
-- neu: pump.init(clamdInStream, 0, 0, false);

Datei install.rdf

- Zeile 15
-- alt: <em:minVersion>6.*</em:minVersion>
-- neu: <em:minVersion>57.*</em:minVersion>

Hallo Flörp, danke für deine Bewertung und den Hinweis für die Änderung!

Das mit meiner Website habe ich hier ganz vergessen, ich bin nun nicht mehr bei einem Freehoster! Das habe ich direkt mal angepaßt, sollte nun wieder stimmen. ;-)

Ich werde mal sehen, wann ich die Änderungen in clamdrib LIN einpflegen kann. Das Problem dabei ist allerdings, daß ich hier SeaMonkey verwende und die sind leider "etwas" hinterher mit neuen Anpassungen. Derzeit kann ich hierzu allerdings keine Auskunft geben, es ist also warten angesagt! :-(

Noté 4 sur 5 étoiles

This addon used to be excellent. It basically just worked (except on emails opened from attachments within other emails). It's marked as incompatible with Thunderbird 60 though, and so now it can't be used at all.

Is it still being developed/supported? The support link is broken.

Can it be updated for Thunderbird 60.* please? I don't know another way of getting email scanning working with ClamAV.

Thanks.

Noté 5 sur 5 étoiles

Malware is not such a problem on Linux OS, but you may be forwarding emails to people with Windows machines so you should make sure the emails are clean.
Installing clamdrib LIN addon for Thunderbird 52 on Ubuntu 16.04.

Install the following packages.
sudo apt-get install clamav clamav-daemon

If you would like additional virus signatures run the following commands:
sudo apt-get update
sudo apt-get install clamav-unofficial-sigs

To install the clamav manuals:
sudo apt-get install clamav-docs
$ man clam <Tab>

Now using a text editor add these two lines to /etc/clamav/clamd.conf
sudo vim /etc/clamav/clamd.conf
TCPSocket 3310
TCPAddr 127.0.0.1
Save changes to clamd.conf

Make sure there are only the following two lines in /etc/systemd/system/clamav-daemon.socket.d/extend.conf
sudo vim /etc/systemd/system/clamav-daemon.socket.d/extend.conf
SocketUser=clamav
ListenStream=127.0.0.1:3310
Save changes to extend.conf

Enter the following since the clamav-daemon.socket changed on disk.
sudo systemctl daemon-reload

Enter the following:
sudo systemctl restart clamav-daemon.service clamav-daemon.socket clamav-freshclam.service

sudo systemctl status clamav-daemon.service clamav-daemon.socket clamav-freshclam.service

The status of the clamav-daemon.socket should be:
Listen: /run/clamav/clamd.ctl (Stream)
127.0.0.1:3310 (Stream)

Enabling Google Safe Browsing service provides lists of URLs that contain malware or phishing content.
The file /etc/clamav/freshclam.conf will have to be edited. First freshclam.conf has to be made writable:
sudo chmod -v u+w /etc/clamav/freshclam.conf

Now edit freshclam.conf using a text editor.
sudo vim /etc/clamav/freshclam.conf
setting: SafeBrowsing true
Save changes to freshclam.conf

Make /etc/clamav/freshclam.conf read only again.
sudo chmod -v u-w /etc/clamav/freshclam.conf


Thank you, TmaWizard

Noté 5 sur 5 étoiles

For ClamAV, we need to edit /etc/clamav/clamd.conf as in Agonybags's review. Then it just works!

Suggestion: an English description would be helpful for future users :)

Cette critique concerne une version précédente du module (0.2.1.8). 

Noté 5 sur 5 étoiles

I have been wanting to get Clamav to work with Thunderbird off and on for some years now. It used to be well supported and then seemed to go off the rails. I have now rebuilt my Gentoo box and used this add-on with Thunderbird. I edited the clamd.conf lines to be the same as these:
TCPSocket 3310
TCPAddr localhost
Then restarted clamd. In the add-on, the test settings easily made the connection. Now I see each email has been scanned. Highly rated. Please keep it updated.

Cette critique concerne une version précédente du module (0.2.1.8). 

Thanks for your feedback!

Gentoo? Nice to read this, so i din't can test it here! ;-)

Aktualy clamdrib LIN 0.2.1.8 works with Thunderbird 48 (nightly), so yes, the support goe's on!

Sorry for my bad english.

Noté 1 sur 5 étoiles

Si blocca il download e oltretutto lo scarica su firefox invece che tu thunderblade. Risolovete

Cette critique concerne une version précédente du module (0.2.1.6). 

Please write in german or english, i dont understand you!