评分5星,满分5星

I'm sure Firefox selected the correct version of Google just fine until the last update. This fixed it again though, thanks