Assegnate 5 su 5 stelle

I was using the fix provided by hsur and newages. It has just stopped working. I just tried the xpi file provided by novalis111 and got the error message "This add on could not be installed because it is not compatible with Thunderbird 68.1.2".

Questo utente ha inserito una recensione precedente su questo componente aggiuntivo.

Assegnate 5 su 5 stelle

I patched it to work with TB 60+ (up to 111)... works fine for me. Also note that you have to change the quote color on replies via CSS. See my gist for download and further instructions for dark TB:

https://gist.github.com/novalis111/4451dbe2e63c72fb4d8f35f7ac8c45c2#thunderbird-dark

Assegnate 5 su 5 stelle

Thanks newages.
I wrote a .bat file that automatically patches the extension to work with Thunderbird 60.

https://gist.github.com/hsur/eac576e62e1a72626b4d510aa4f3acf7

Assegnate 5 su 5 stelle

Quote Colors extension working correctly in Thunderbird 60.

Fix:

* install.rdf

Code: Select all
- <em:version>0.3.1-let-fixed</em:version>
+ <em:version>0.3.1.1</em:version>


Code: Select all
- <em:maxVersion>3.0.*</em:maxVersion>
+ <em:maxVersion>60.*</em:maxVersion>


* \chrome\quotecolors.jar\content\quotecolors\qc_overlay.js

Code: Select all
- this.oPrefServ.QueryInterface(Components.interfaces.nsIPrefBranchInternal);
+ this.oPrefServ.QueryInterface(Components.interfaces.nsIPrefBranch);

Assegnate 5 su 5 stelle

Amazing! I change to maxVersion 52.0.* and it works.
Thanks "cprasmussen".

Assegnate 5 su 5 stelle

Follow instruction by "cprasmussen" of February 8, 2017.

Thunderbird should pickup this add-on in make it part of TB.

Assegnate 5 su 5 stelle

Unzip the xpi file quote_colors-0.3-tb+sm.xpi
On line 14 and 22 set <em:maxVersion>52.0.*</em:maxVersion> (52 is completely random)
Zip all files to quote_colors-0.3-tb+sm.zip and rename to quote_colors-0.3-tb+sm.xpi

Assegnate 5 su 5 stelle

An simple, yet extremely useful add-on which makes life easier for those of us who follow mailing lists and discussions. Why this functionality has never made it to the main TB code escapes me completely. To add insult to injury, the add-on itself has been abandoned.

Assegnate 5 su 5 stelle

Works with Thunderbird 38.1.0

I just had to change
<!-- Thunderbird -->
..
<em:maxVersion>3.0.*</em:maxVersion>
to
<em:maxVersion>39.0.*</em:maxVersion>

in install.rdf
Works fine

Assegnate 5 su 5 stelle

Здравствуйте, не работает Плагин на Thunderbird 31.5 Windows
Редактировал установочный файл, все равно не помогло
<em:maxVersion>36.*</em:maxVersion>

Assegnate 5 su 5 stelle

The compatibility value should be changed for this add-on, as it works PERFECTLY in TB 24.0!

This is a great extension! It makes reading messages with multiple replies SO much easier, as you can see exactly where one level ends and another level starts.

Stop counting ">"s! Use this instead!

Assegnate 4 su 5 stelle

This add-on still works if I extract it and edit the MaxVersion in install.rdf. Could there be just a quick update to this add-on to allow it to install without hacks on modern Thunderbird versions?

Assegnate 4 su 5 stelle

Is there a way to get this to work on TB17? It's a great add-on, but will not load on TB17.
Thx,
Henri

Assegnate 5 su 5 stelle

...as previously mentioned in the howto in one of the reviews, you update the maxVersion in the install.rdf.

Assegnate 1 su 5 stelle

Modify maxVersion but In Thunderbird 14+ still does not work...??!

Assegnate 1 su 5 stelle

It is as if it isn't even there- and this is on TB 3.1.20.

Assegnate 5 su 5 stelle

...you update the maxVersion in the install.rdf as mentioned in the howto in one of the reviews. I wish the author would do this ...or at least express his desire to let someone else who is interested in doing this, take over.

Assegnate 5 su 5 stelle

Fonctionne trés bien dans Thunderbird 10 (mais il faut hacker le fichier install.rdf car l'auteur ne s'en occupe plus)

Pourquoi Mozilla ne valide pas automatiquement ce trés utile plugin ?

Assegnate 4 su 5 stelle

A star off because I HAD to do it myself...
In config editor find the line: extensions.minCompatibleAppVersion, and change the value to 0.3.

Worked for me immediately! Be nice if the author would update this really cool add-on.

Assegnate 5 su 5 stelle

Works on Thunderbird 10.0, after modifying the max version # in the install.rdf file. The how-to looks complicated, but it's straightforward.

I would like that Mozilla changes its stupid major release frenzy.