Rated 5 out of 5 stars

Even if I start Thunderbird from the mac window menu, LaTex It! works like a charm. Very user friendly, for instance, the undo option is super in order to make corrections. Thanks mr. Protzenko!

Rated 5 out of 5 stars

Your extension is awesome and the only one I need in my daily life.

Please update it to support TB 68. Since its release and update on my linux distros, it no longer functions even when disabling strict version checking!

This review is for a previous version of the add-on (0.6.7). 

Rated 4 out of 5 stars

Super add-on that changes life. It works perfectly under Windows with MiKTeX but I can't get it to work under Ubuntu 18.04. The texlive packages are installed via "texlive-full" so "texlive-latex-extra" is well installed. Yet I have the classic error message :


LatexIt! run report...

*** Found expression $x$
convert failed with error code 1. Aborting.
Possible explanations include:
- you're running Windows, and you didn't install Ghostscript
- you're running OSX, and you didn't launch Thunderbird from a Terminal

Please see http://github.com/protz/LatexIt/wiki

This review is for a previous version of the add-on (0.6.7). 

Rated 5 out of 5 stars

It worked great for years. Since thunderbird 60, it did not work because of incompatibility. However, I could install directly from github https://github.com/protz/LatexIt : the issue was mentioned and a work around was proposed.

This review is for a previous version of the add-on (0.6.4). 

Rated 1 out of 5 stars

Since then, I switched to *MarkDownHere* extension which supports TeX syntax and is working great (I am also using Markdown more and more often instead of TeX).
Nevertheless I hope LaTeXit will be updated to be compatible with Thunderbird >=60. Very nice plugin, easy to setup and use when using thunderbird <60.

This review is for a previous version of the add-on (0.6.4). 

Rated 5 out of 5 stars

Awesome, easy to use and useful for scholar emails

This review is for a previous version of the add-on (0.6.4). 

Rated 4 out of 5 stars

Very useful add on. Beware for mac users, ImageMagick in necessary to have the convert tool properly installed.

This review is for a previous version of the add-on (0.6.4). 

Rated 4 out of 5 stars

I have been using LaTeX It quite often for quite some time now. It is amazing that I can use amsmath, amssymb, amsthm packages as well as the Xy-pic package quite effectively. I use inline categorical diagrams and this has been a great add-on, since I can just write my mathematics directly in the email.

Some queries: would it be possible to add support for tikz pictures using tikz package ?

Would it be possible to use commands defined using \newcommand elsewhere ?

This review is for a previous version of the add-on (0.6.4). 

Rated 2 out of 5 stars

This is a fantastic add-on that I have used happily for several years. However it is now broken due some changes made elsewhere in Thunderbird: see https://www.mozilla.org/en-US/thunderbird/52.0/releasenotes/ -- 'the way images are included'. It would be great if this can be fixed!

This review is for a previous version of the add-on (0.6.2). 

Rated 5 out of 5 stars

Does what it says and says what it does. It's got the right ta-ta and the right ho-ho.

This review is for a previous version of the add-on (0.6.2). 

Rated 5 out of 5 stars

Excellent add-on if you already have a working LaTeX installation. It's so nice to be able to send proper mathematical notation in email.

This review is for a previous version of the add-on (0.6.2). 

Rated 5 out of 5 stars

This is better than sliced bread. It makes e-mail usable for technical communication.

This review is for a previous version of the add-on (0.6.2).  This user has a previous review of this add-on.

Rated 5 out of 5 stars

Beautiful! Works exactly as expected!

This review is for a previous version of the add-on (0.6.2). 

Rated 5 out of 5 stars

This is the most awesome plugin for Thunderbird. Worked like a charm on my Ubuntu 14.04 system since I already had TexLive installed--it just found TeX install and I'm typing equations to my students like mad.

One thing I just found though is that I don't seem to be able to properly escape a "$" between the $$ and $$ pairs. WHen I put a \$ in an equation, LaTeX complains. I can do it with an "insert complex Latex" function, but I thought you might like to know.

Thanks Jonathan!

This review is for a previous version of the add-on (0.6.2). 

Rated 5 out of 5 stars

I'm very happy with this add-on. It worked practically out of the box on my Debian system. For me the best feature is its support for additional packages and macros. Thank you!

This review is for a previous version of the add-on (0.6.2). 

Rated 5 out of 5 stars

Excellent addon! I would suggest using preview.sty + dvipng directly instead of dvips + imagemagick for greater speed. Thanks!

This review is for a previous version of the add-on (0.6.2). 

Rated 5 out of 5 stars

Wow! Simply useful, beautiful and easy to use. Thanks!

This review is for a previous version of the add-on (0.6.2). 

Rated 5 out of 5 stars

Excellent tool to realize what I was looking for, for quite some time. Perhaps a somewhat more detailed documentation for full use of this module with texlive would save time. It is not easy to understand immediately how works this great tool. Thank you so much, Jonathan.

This review is for a previous version of the add-on (0.6.2). 

Rated 5 out of 5 stars

Exactly what I've been looking for. Works perfectly with Thunderbird 17.0 under Ubuntu 12.04, after manually adding the "LaTeX it!" button. Now I finally can write proper emails when discussing mathematics with someone.Thank you so much, Jonathan. Keep up the great work.

This review is for a previous version of the add-on (0.6.2). 

Rated 1 out of 5 stars

On the "Write" window, "Latex it!" has not been added to my toolbar.
I use Thunderbird_7.01 + WindowsXP_64

Notes:
- On cygwin, [utf8x] is not recognized either.
- I have installed everything as requested on 32bits versions (ghostscript+imagemagic).

This review is for a previous version of the add-on (0.6.2).